DeviceImage Tools Forum Index DeviceImage Tools
Forum to discuss all about device-image tools
 
 FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

clone problem, please help

 
Post new topic   Reply to topic    DeviceImage Tools Forum Index -> Using localy
View previous topic :: View next topic  
Author Message
roti
Guest





PostPosted: Thu Aug 25, 2005 4:01 pm    Post subject: clone problem, please help Reply with quote

Hi!

We have some machine, which is protected by a PCI hardware card named Magic Card Extra by http://www.rogev.com/products/extra.htm.
This card can separate partitions from each other (I think by modifying the partition tables's id on the fly).
The card has a built in disk copy function, which we had used with success. But now, we would like to use another method to clone. Here comes zsplit:
I made a splitted image to fat32 from an usb attached mobile rack
zsplit -s 2G -o /mnt/win_e -N 300 -d /dev/sda
then I restored it, to another disk:
unzsplit -D /dev/sda -i /mnt/win_e -d 300
The logfile showed that it is OK.

Putting this clone disk to a machine with the Magic card, and starting any operating system from the card's menu, it will give the well known error message:
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER

Is there a way to clone the disk bit by bit?

Thanx
Roti
Back to top
jurij
Site Admin


Joined: 05 Apr 2005
Posts: 54
Location: Germany

PostPosted: Tue Aug 30, 2005 11:16 pm    Post subject: Reply with quote

Hi Roti,

After some considerations about possible error situations in your case I can see here following issues which can cause this failure:

1. The method of copying which zsplit uses is the “byte by byte�-method, only this method can produce an image of hard disc. Therefore we should search for a possible cause of this error on the side of this PCI-Card or in the logical assignment of the device.

2. The error message “DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER� says that the MBR (master boot record) cannot be found. The system cannot find bootable device.

3. You should be sure that the cloned disk is recognized with the same device name (/dev/sda) as the device from which the image has been done before, it is very important in case of cloned bootable devices.

4. Also is important to know if the bootable device in BIOS is the same, the BIOS should also know where to search for a MBR.

5. As I can see from the docu for your PCI-Card there is a “VxD driver� which is installed in the MBR so may be you should try following: “The VxD driver is not installed properly, or it is set to run in 16-bit mode.To solve this, select the checkbox in Update Boot Code in Hard Disk MBR in system parameters in the system menu.�

6. The next possibility: “initialization mode of Magic Card is incorrect. Modes 1 to 4 are lined as per functional intensifying and compatibility lowering in turn. For ISA edition, switching among these 4 kinds of initialization modes can adjust address of ROM. Addresses corresponding to initialization mode 1/2/3/4 are D000H/C800H/D400H/D800H. For PCI and LAN edition, adjust jumpers or execute SETPCI.COM or press Alt+1/2/3/4 key after the completion of initialization of memory and hard disk. For example, you can press both Alt and 1 key to set compatibility of Magic Card with ASUS motherboard.�

I hope this information will help you to resolve this boot problem.

Regards,
Jurij
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Roti
Guest





PostPosted: Mon Sep 05, 2005 10:51 am    Post subject: Reply with quote

HI!

It was the BIOS settings...
I made the oldschool fault: forgot to set the HD as a boot device.
So it is working now.

Thanx Jurij!


Roti
Back to top
Display posts from previous:   
Post new topic   Reply to topic    DeviceImage Tools Forum Index -> Using localy All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Board Security

200600 Attacks blocked

Powered by phpBB © 2001, 2005 phpBB Group