DeviceImage Tools Forum Index DeviceImage Tools
Forum to discuss all about device-image tools
 
 FAQFAQ   SearchSearch   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

cloning disks newbie: getting usage

 
Post new topic   Reply to topic    DeviceImage Tools Forum Index -> Using over the network
View previous topic :: View next topic  
Author Message
ldh
Guest





PostPosted: Fri Jan 13, 2006 9:10 pm    Post subject: cloning disks newbie: getting usage Reply with quote

I'm a brand new user of DeviceImage, having been referred here by the PartitionImage forum. I am searching for a tool that will clone two Windows PCs across the network w/o using intermediate files. I was using SystemRescueCD and partimage, but didn't want to do an ntfsresize to shrink the NTFS partition of the source machine so it can fit on the target machine with the same size disk.

I typed commands from the "Network Situation 2" example (last one in the document) and I get a unzsplit usage error in the debug output file of the system B. I have installed zsplit and unzsplit on my SystemRescueCD, so I type the following commands.

Source:
/mnt/cdrom/zsplit -c -d /dev/hda |nc <target IP> 9000

Target:
nc -l -p 9000 |/mnt/cdrom/unzsplit -D /dev/hda -d

Any idea what I'm doing wrong?

Thanks in advance,

Larry
larry.hybl@ncr.com
Back to top
Guest






PostPosted: Fri Jan 13, 2006 9:44 pm    Post subject: Re: cloning disks newbie: getting usage Reply with quote

duh. I didn't put the - (for stdin) at the end of the "nc|unzsplit" pipeline. It's performing the network clone as I type this. Can't wait to see how long it takes!

larry

[quote="ldh"]I'm a brand new user of DeviceImage, having been referred here by the PartitionImage forum. I am searching for a tool that will clone two Windows PCs across the network w/o using intermediate files. I was using SystemRescueCD and partimage, but didn't want to do an ntfsresize to shrink the NTFS partition of the source machine so it can fit on the target machine with the same size disk.

I typed commands from the "Network Situation 2" example (last one in the document) and I get a unzsplit usage error in the debug output file of the system B. I have installed zsplit and unzsplit on my SystemRescueCD, so I type the following commands.

Source:
/mnt/cdrom/zsplit -c -d /dev/hda |nc <target IP> 9000

Target:
nc -l -p 9000 |/mnt/cdrom/unzsplit -D /dev/hda -d

Any idea what I'm doing wrong?

Thanks in advance,

Larry
larry.hybl@ncr.com[/quote]
Back to top
Admin
Site Admin


Joined: 04 Apr 2005
Posts: 3

PostPosted: Fri Jan 13, 2006 10:45 pm    Post subject: Reply with quote

Hi Larry,

You are absolutely right, the stdin option “-“ was missing. I should see how to change it in my docu html-page to make it more obviously.
The time for cloning depends only on the network performance, this is the bottleneck for this scenario.
Could you post here some test results, such as network speed, device-size and time you needed to clone the device?

Thanks,
Jurij
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    DeviceImage Tools Forum Index -> Using over the network All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Board Security

198699 Attacks blocked

Powered by phpBB © 2001, 2005 phpBB Group